VTEX só vai dar suporte ao TLS 1.2

Daniel Aleixo

Daniel Aleixo

Última atualização

Como parte do nosso processo de melhoria contínua, vamos passar a dar suporte apenas para integrações que usam TLS 1.2. A partir de 30 de junho, versões anteriores do TLS e todas as versões do SSL vão ser descontinuadas.

Essa mudança está em conformidade com os requisitos PCI DDS e é fundamental para manter a segurança da plataforma.

O que você precisa fazer

Se você é uma agência ou um provedor de pagamentos e usa a API do PCI Gateway, revise suas integrações e atualize para o TLS 1.2 o quanto antes.

A partir do servidor que se comunica com nossos endpoints, teste sua conexão com um GET na URL https://securetlspci.vtexpayments.com.br/. Se ele retornar 200 OK, significa que você já está em conformidade com o TLS 1.2 e não vai precisar tomar nenhuma ação. Veja o exemplo abaixo:

curl -X GET \
https://securetlspci.vtexpayments.com.br/ \
-H 'accept: text/html'

Se você for um lojista

Lojistas não precisam se preocupar nem tomar nenhum tipo de ação. Mas se quiser, você pode entrar em contato com os responsáveis pelas integrações de pagamento da sua loja para perguntar se eles já estão em conformidade com o TLS 1.2.