VTEX will only give support to TLS 1.2

Daniel Aleixo

Daniel Aleixo

Last updated

As part of our constant improvement, we will only give support to integrations using the TLS 1.2 protocol. As of June 30th, TLS previous versions and all SSL versions will be deprecated. Those changes are PCI DDS compliant and are necessary to keep the platform secure.

What you need to do

If you're part of an agency or a payment provider and uses the PCI Gateway's API, then you must review your integrations and upgrade to TLS 1.2 as soon as possible.

You can test your connection from the server that connects to our endpoints. Just make a GET request in the following URL: https://securetlspci.vtexpayments.com.br/. If it returns 200 OK, that means you're already compliant with the TLS 1.2 protocol. Therefore, you won't need to perform any actions. See the example below:

curl -X GET \
https://securetlspci.vtexpayments.com.br/ \
-H 'accept: text/html'

If you work on a store

Stores don't need to take any actions. But feel free to contact your agency or provider and check if their payment integrations are already compliant with the TLS 1.2 protocol.